CodeIgniter 2.1.3 güncellemesi

CodeIgniter yeni versiyonu 2.1.3’ü bu hafta yayımladı. 2.x serisinin en son çıkan stabil versionunda, tespit edilen bug’lar düzeltildi. Eğer kullanıcılardan gelen IP adreslerini kullandığınız bir uygulamanız varsa, yeni versiyona yükseltmeniz önerilir.

Yapılan diğer önemli değişiklikler:

  • Session kütüphanesinde, sess_destroy() methodu, userdata dizisini silmiyordu, düzeltildi.
  • Profiler kütüphanesi eğer session kütüphanesi userdata objesi kullanıyorsa E_WARNING hatası veriyordu, düzeltildi.
  • Input kütüphanesi, daha güvenli hale getirildi.
  • CSRF saldırılarını kontrol ve önlemek için ek önlemler alındı.

Önceki versiyonlardan nasıl geçiş yapılacağını öğrenmek için Upgrading linkini takip edebilirsiniz.

CodeIgniter’ın tüm versiyonlarına erişmek için download sayfasını inceleyiniz.

Yanıt Gönder